Starknet OS bug found and resolved
Incident Report for Starknet
Postmortem

At 12:41 PM UTC, there was an alert pointing to internal inconsistency between the executions of the sequencer OS in block 619408. An investigation identified a bug in the OS implementation of the get_block_timestamp syscall which caused it to return incorrect values. The OS was fixed. Upon verifying consistent execution of the fixed OS version with the sequencer, the Starknet core contract was updated to recognize the new OS hash. Following the fix, L1 state updates proceeded normally.

Effect on users:

  1. L2 was unaffected (no reorgs nor delays in sequencing).
  2. L1 finality was delayed by several hours.
Posted Mar 17, 2024 - 10:45 UTC

Resolved
There is an inconsistency between the executions of the sequencer OS of block 619408. The issue is under investigation.
Posted Mar 16, 2024 - 10:41 UTC